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Chapter-4 Spreadsheet

Q.no. 1 write any five advantages using electronic spreadsheet in place 

of manual spreadsheet? 
 

Answer: 
(i) Unlike manual spreadsheets, electronic 

graphical presentations of data. 

 

(ii) Unlike manual spreadsheets, electronic spreadsheets have superior editing and formatting tools 

as well as various styles and layouts.

 

(iii) They have inbuilt recalculation functions that adjust values automatically when changes are 

made in the spreadsheets, which is nonexistent in manual spreadsheets.

 

(iv) The quality of the work is very high because such work is neat and legible compared to paper, 

pencil and eraser work. 

 

(v) It takes the advantages of computer system such as accuracy, high speed and versatility.

 

(vi) Electronic spreadsheet has a large sheet for data manipulation.

For instance, in Ms Excel 2003, there are 255 columns and 65536 rows in a singl

2010 has 16384 columns and 1048576 rows.

 

(vii) Takes advantage of large secondary storage devices in a computer to store voluminous data.

 

Q.no. 2 define workbook and worksheet what is difference between 

them? 

Answer : 

Understanding a Worksheet

The worksheet in a Microsoft Excel 2010 file is a single spreadsheet consisting of rows and 

columns. When you first launch Excel and are presented with a view similar to the one below, 

then the majority of the screen is taken up by the default wo
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(i) Unlike manual spreadsheets, electronic spreadsheets have sophisticated analysis tools as well as 

(ii) Unlike manual spreadsheets, electronic spreadsheets have superior editing and formatting tools 

as well as various styles and layouts. 

recalculation functions that adjust values automatically when changes are 

made in the spreadsheets, which is nonexistent in manual spreadsheets. 

(iv) The quality of the work is very high because such work is neat and legible compared to paper, 

(v) It takes the advantages of computer system such as accuracy, high speed and versatility.

(vi) Electronic spreadsheet has a large sheet for data manipulation. 

For instance, in Ms Excel 2003, there are 255 columns and 65536 rows in a single sheet. Ms Excel 

2010 has 16384 columns and 1048576 rows. 

(vii) Takes advantage of large secondary storage devices in a computer to store voluminous data.
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Worksheet 

The worksheet in a Microsoft Excel 2010 file is a single spreadsheet consisting of rows and 

columns. When you first launch Excel and are presented with a view similar to the one below, 

then the majority of the screen is taken up by the default worksheet. 
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write any five advantages using electronic spreadsheet in place 

spreadsheets have sophisticated analysis tools as well as 

(ii) Unlike manual spreadsheets, electronic spreadsheets have superior editing and formatting tools 

recalculation functions that adjust values automatically when changes are 

(iv) The quality of the work is very high because such work is neat and legible compared to paper, 

(v) It takes the advantages of computer system such as accuracy, high speed and versatility. 

e sheet. Ms Excel 

(vii) Takes advantage of large secondary storage devices in a computer to store voluminous data. 

Q.no. 2 define workbook and worksheet what is difference between 

The worksheet in a Microsoft Excel 2010 file is a single spreadsheet consisting of rows and 

columns. When you first launch Excel and are presented with a view similar to the one below, 



 

Jawahar Computer Education® Head Office-873/1, Sec-I, Aashiyana, Near Sai Temple, Lucknow. 

 
 The name of your first worksheet is Sheet1, if your Excel program is still using the default 

settings. Your worksheet typically contains a series of rows that are identified with numbers at 

the left side of the window, and columns that are identified with letters at the top of the window. 

This is the default setup in Excel 2010, and is the most commonly used structure in the program. 

 Understanding a Workbook 

A workbook in Microsoft Excel 2010 is the entire Excel file (typically identified with a file type 

of .xls or .xlsx). If you see an Excel file in your My Documents folder, then that file is a 

workbook. 

 
A new Excel file will have a default name of Book1, although that can later be changed when you first 

save the file. Your workbook can consist of multiple worksheets (a new file in a default Excel installation 

will have three worksheets), as well as information about the file itself, including macros, author names, 

and more. But even if there is only one worksheet in your Excel workbook, then that entity would still be 

called a workbook, simply because it has the capacity to hold more worksheets. 

Difference between a Worksheet and a Workbook in Excel 

Perhaps the easiest way to understand the difference between a worksheet and a workbook is to 

think of it in terms of pages in a book.  

1. The workbook is the entire book, while the worksheet is a single page within that book.  

2. A workbook can contain, at minimum, one worksheet, and up to a very large number of 

worksheets that is only limited by the available memory on your computer.  

3. Worksheets can be added, deleted or renamed within the workbook.  

4. You can also rename a workbook without affecting the name of any of the worksheets. 

5.  You can toggle between worksheets within your workbook by clicking the sheet tabs at 

the bottom of the window. 
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Q.no 3 Explain active worksheet.

Answer: 

In spreadsheet programs such as Excel or Google Spreadsheets, the active cell is

colored border or outline surrounding the

1. The active cell is always in the active sheet.

2. The active sheet or current sheet

active cell, the active sheet

actions that affect one or more cells 

the active sheet by default.

3. The active cell and sheet

clicking another cell with the mouse pointer or

will both result in a new active cell being selected.

Change the active sheet by clicking a different sheet tab with

keyboard shortcut. 

Q.no 4 what are formulas and how are they created?

Answer: 

A formula is an expression telling the computer what mathematical operation to

specific value. When referring to computer software, formulas are most often used 

in spreadsheet programs, such as Microsoft

to quickly make calculations and get totals of multiple

In the picture below is an example of a Microsoft Excel formula

the total of cells A1, A2, and A3. In this formula, SUM is the
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Q.no 3 Explain active worksheet. 

In spreadsheet programs such as Excel or Google Spreadsheets, the active cell is

colored border or outline surrounding the cell.  

The active cell is always in the active sheet. 

current sheet is the worksheet containing the active cell. Like the 

cell, the active sheet is considered to have focus when it comes to

actions that affect one or more cells — such as formatting — and the changes occur to 

active sheet by default. 

The active cell and sheet can easily be changed. In the case of the active cell, either 

clicking another cell with the mouse pointer or pressing the arrow keys on the keyboard 

will both result in a new active cell being selected. 

Change the active sheet by clicking a different sheet tab with the mouse pointer or by using a 

 

are formulas and how are they created? 

telling the computer what mathematical operation to

specific value. When referring to computer software, formulas are most often used 

programs, such as Microsoft Excel. Using formulas in spreadsheets can allow you 

to quickly make calculations and get totals of multiple cells, rows, or columns in a spreadsheet.

In the picture below is an example of a Microsoft Excel formula =SUM(A$1:A

the total of cells A1, A2, and A3. In this formula, SUM is the function of the formula.
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In spreadsheet programs such as Excel or Google Spreadsheets, the active cell is identified by a 

ive cell. Like the 

focus when it comes to performing 

and the changes occur to 

be changed. In the case of the active cell, either 

the arrow keys on the keyboard 

the mouse pointer or by using a 

telling the computer what mathematical operation to perform upon a 

specific value. When referring to computer software, formulas are most often used 

. Using formulas in spreadsheets can allow you 

in a spreadsheet. 

1:A$3), which adds 

of the formula. 
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How to make a simple Excel formula by using constants and operators 

In Microsoft Excel formulas, constants are numbers, dates or text values that you enter directly 

in a formula. To create a simple Excel formula using constant, just do the following: 

1. Select a cell where you want to output the result. 

2. Type the equal symbol (=), and then type the equation you want to calculate. 

3. Press the Enter key to complete your formula. 

Here is an example of a simple subtraction formula in Excel: =100-50 

How to write formulas in Excel using cell references 

Instead of entering values directly in your Excel formula, you can refer to the cells, containing 

those values. 

For example, if you want to subtract a value in cell B2 from the value in cell A2, you write the 

following subtraction formula: =A2-B2 

 
When making such a formula, you can type the cell references directly in the formula, or click 

the cell and Excel will insert a corresponding cell reference in your formula. To 

add range reference, select the range of cells in the sheet. 

 
Note. By default, Excel adds relative cell references. To switch to another reference type, press 

the F4 key. 

A big advantage of using cell references in Excel formulas is that whenever you change a value 

in the referred cell, the formula recalculates automatically without you having to manually 

update all the calculations and formulas on your spreadsheet. 
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Q.no 5 Define pivot table and explain its usage.

Answer: 

A pivot table is a summary of yo

trends based on your information. Pivot tables are particularly useful if you have long rows or 

columns that hold values you need to track the sums of and easily compare to one another.

How to Create a Pivot Table 

1. Enter your data into a range of rows and columns.

2. Sort your data by a specific attribute.

3. Highlight your cells to create your pivot table.

4. Drag and drop a field into the "Row Labels" area.

5. Drag and drop a field into the "Values" area

6. Fine-tune your calculations. 

 

Example 

Insert a Pivot Table 
To insert a pivot table, execute the following steps.

1. Click any single cell inside the data set.

2. On the Insert tab, in the Tables group, click PivotTable.

 

The following dialog box appears. Excel automatically selects the data for you. The default location for a 

new pivot table is New Worksheet. 

3. Click OK. 

Sort 
To get Banana at the top of the list, sort the pivot table.

1. Click any cell inside the Sum of Amount column.

2. Right click and click on Sort, Sort Largest to Smallest.
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A pivot table is a summary of your data, packaged in a chart that lets you report on and explore 

trends based on your information. Pivot tables are particularly useful if you have long rows or 

columns that hold values you need to track the sums of and easily compare to one another.

Enter your data into a range of rows and columns. 

Sort your data by a specific attribute. 

Highlight your cells to create your pivot table. 

Drag and drop a field into the "Row Labels" area. 

Drag and drop a field into the "Values" area. 

, execute the following steps. 

1. Click any single cell inside the data set. 

2. On the Insert tab, in the Tables group, click PivotTable. 
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1. Click any cell inside the Sum of Amount column. 
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ur data, packaged in a chart that lets you report on and explore 

trends based on your information. Pivot tables are particularly useful if you have long rows or 

columns that hold values you need to track the sums of and easily compare to one another. 
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Result After sorting is given below

Filter 
Because we added the Country field to the Filters area, we can filter this pivot table by Country. For 

example, which products do we export the most to France?

1. Click the filter drop-down and select France.

Result. Apples are our main export product to France.

Note: you can use the standard filter (triangle next to Row Labels) to only show the amounts of specific 

products. 
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Note: you can use the standard filter (triangle next to Row Labels) to only show the amounts of specific 
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Q.no 6 What is auto sum in Excel?

Answer: 

The AutoSum feature makes it very easy to total rows and columns using the

function. 

There is a special command button on the standard toolbar that will allow 

function very quickly. 

This command button is known as the

Step: 1. Click on Home button 

 2. Click on Auto sum button in Editing Group.

 

You can quickly enter the AVERAGE

down menu. 

The "More Functions" button displays the

You can also use the shortcut key

Q.no 7 What is Excel Sort & Filter?

Answer: 

The sorting tool allows you to sort by date, number, alphabetic order and more. In the following 

example, we will explore the usage of sorting and filtering and show some advanced sorting 

techniques. 

As you can see, the order dates, order numbers, prices, etc. are all out of order. 
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Q.no 6 What is auto sum in Excel? 

The AutoSum feature makes it very easy to total rows and columns using the SUM

There is a special command button on the standard toolbar that will allow you insert the SUM 

This command button is known as the AutoSum button. 

 

2. Click on Auto sum button in Editing Group. 

AVERAGE, COUNT, MAX or MIN functions by expanding the drop

The "More Functions" button displays the (Insert > Function) dialog box. 

You can also use the shortcut key (Alt + =) to quickly sum the adjacent cells. 

Q.no 7 What is Excel Sort & Filter? 

The sorting tool allows you to sort by date, number, alphabetic order and more. In the following 

example, we will explore the usage of sorting and filtering and show some advanced sorting 

 
As you can see, the order dates, order numbers, prices, etc. are all out of order.  
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SUM worksheet 

you insert the SUM 

functions by expanding the drop-

The sorting tool allows you to sort by date, number, alphabetic order and more. In the following 

example, we will explore the usage of sorting and filtering and show some advanced sorting 
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Sorting Data 

Let’s say you had the spreadsheet above and wanted to sort by price. This process is fairly 

simple. You can either highlight the whole column or even cli

get started. Then you will: 

1. Right click to open the menu

2. Go down to the Sort option 

3. Click on Largest to Smallest

4. Select Expand the selection

5. Click OK 

 

Filtering Data 

 

The filter feature applies a drop down menu

specific choices to narrow a table. Using the above example, let’s say you wanted to filter your 

table by Company and Salesperson. Specifically, you want to find the

Rogers made to Eastern Company.

To do this using the filter you would:

1. Go to the Data tab on Excel ribbon

2. Select the Filter tool 

3. Select Eastern Company from the dropdown menu

4. Select Dylan Rogers from the Salesperson dropdown menu

 

Q.no 8 how will you insert and remove sheets from workbooks in excel?

Answer: 

Insert a worksheet 

• Select the    plus icon at the bottom of the screen.

• Or, select Home > Insert 
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Let’s say you had the spreadsheet above and wanted to sort by price. This process is fairly 

simple. You can either highlight the whole column or even click on the first cell in the column to 

Right click to open the menu 

Go down to the Sort option – when hovering over Sort the sub-menu will appear

Click on Largest to Smallest 

Select Expand the selection 

The filter feature applies a drop down menu to each column heading, allowing you to select 

specific choices to narrow a table. Using the above example, let’s say you wanted to filter your 

table by Company and Salesperson. Specifically, you want to find the number of sales Dylan 

Rogers made to Eastern Company. 

To do this using the filter you would: 

Go to the Data tab on Excel ribbon 

Select Eastern Company from the dropdown menu 

Select Dylan Rogers from the Salesperson dropdown menu 

no 8 how will you insert and remove sheets from workbooks in excel?

plus icon at the bottom of the screen. 

 > Insert Sheet. 
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Let’s say you had the spreadsheet above and wanted to sort by price. This process is fairly 

ck on the first cell in the column to 

menu will appear 

to each column heading, allowing you to select 

specific choices to narrow a table. Using the above example, let’s say you wanted to filter your 

number of sales Dylan 

no 8 how will you insert and remove sheets from workbooks in excel? 
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Delete a worksheet 

• Right-click the Sheet tab and select

• Or, select the sheet, and then select

Q.no 9 defines any 5 functions of spreadsheet program.

Answer: 

A function is a predefined formula

particular order. All spreadsheet programs include common functions that can be used for 

quickly finding the sum, average

cells. 

Using functions 

There are a variety of functions. Here are some of the most common 

1. SUM: This function adds

2. AVERAGE: This function determines the

argument. It calculates the sum of the cells and then divides that value by the number of

cells in the argument. 

3. COUNT: This function counts

This function is useful for quickly counting items in a cell range.

4. MAX: This function determines the

5. MIN: This function determines the
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tab and select  Delete. 

Or, select the sheet, and then select Home > Delete > Delete Sheet. 

 
Q.no 9 defines any 5 functions of spreadsheet program. 

predefined formula that performs calculations using specific values in a 

readsheet programs include common functions that can be used for 

average, count, maximum value, and minimum value

 

 

 

 

 

 

 

 

 

 

There are a variety of functions. Here are some of the most common functions you'll use:

adds all the values of the cells in the argument. 

: This function determines the average of the values included in the 

argument. It calculates the sum of the cells and then divides that value by the number of

counts the number of cells with numerical data in the argument. 

This function is useful for quickly counting items in a cell range. 

: This function determines the highest cell value included in the argument.

: This function determines the lowest cell value included in the argument.
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that performs calculations using specific values in a 

readsheet programs include common functions that can be used for 

minimum value for a range of 

functions you'll use: 

of the values included in the 

argument. It calculates the sum of the cells and then divides that value by the number of 

the number of cells with numerical data in the argument. 

included in the argument. 

included in the argument. 
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